タグ別アーカイブ: 統合

2008-11
03
23:55:00
ニコニコPodder R1.0.8をリリースしました


再度のリリースで申し訳ないですが、XP環境のIE7でブラウザ認証統合が行えない問題を修正しました。
これも恐らくR1.0.3あたりから紛れ込んでいたかと思います。ご迷惑おかけしました。
IEでのブラウザ認証統合については、IE7 on Vista、IE6 on XP、IE7 on XPの各パターンにて確認しています。
その他のIE互換ブラウザについては積極的に対応の予定はありませんが、コメントで頂いた問題は今回のバージョンで解決できているかも知れません。
一応情報開示しておきますと、内部のキャッシュ管理構造の違いから、IE7とIE6(正確にはIE7以外)は別の方法で認証情報を取得しています。
ただしIE7 on XPではIE6と同様のキャッシュ管理を行うため、今回の問題を引き起こしていました。
なお、何らかの理由でIE7の認証を強制したい場合はnicopodder.iniの[nicoPodder]セクションに「ForceIE7Authentication=True」という1行を加えて下さい。
ブラウザ認証統合をIEで行っている場合には、IE7として取り扱われるようになります。
何かありましたらコメント欄までお願いします。
* R1.0.9をリリースしました。今後はそちらへどうぞ

2008-11
02
05:20:00
ニコニコPodder R1.0.7をリリースしました


コメントで頂いた障害などについて修正しました。
■Google Chromeがインストールされていた場合、Firefoxでブラウザ認証統合が行えなかったバグを修正しました
R1.0.3以降紛れていた模様です。Firefox2/3ともに影響を受けていました。
■IE7でブラウザ認証統合が行えない場合があったのを修正しました
同じくR1.0.3以降起こっていたと思われます。
IE7で保護モードが有効の場合にCookieが読み込めないケースがあったと思います。
テスト不足でごめんなさい。。
■ダウンロード先フォルダ、変換先フォルダに大量のファイルが存在した場合処理速度が低下する問題を回避(したつもり)
テスト環境が整わないので、あくまで「つもり」です。
以上ですが何かありましたらコメント欄までどうぞ。
* R1.0.8をリリースしました。今後はそちらへどうぞ

2008-07
05
07:15:00
ニコニコPodder R1.0.2をリリースします


コメントでも頂いていましたので、Firefox3との認証統合に対応したR1.0.2をリリースします。
また1.0.0以降にてエコノミーモード時の変換ファイル名がノーマル時のものになってしまっていたようですので、これも修正しました。
何かありましたらコメント欄までどうぞ。
* R1.0.3をリリースしました。今後はそちらへどうぞ