2006-04
07
20:25:00
Qtek9000用新ROMを導入してみた


20060407200710.jpgきょん☆あさん経由で、とうとうQtek9000用の新ROM(AKU2)が公開されたことを知ったので、さっそく導入してみました。
i-mate用などは既に先月から公開されていて、「さくさく動く」「BluetoothでA2DPが使える」など評判も上々のようだったので、Qtek9000用が公開されるまでわくわくしながら待ち望んでいたのでした。
基本的には問題なく導入可能だったのですが、それはHTC Universalのこと、幾つか問題も含んでいたり。


■カスタマイズROMでは導入不可?
最初は以前のROMと同じく日本語化(CE-STAR + ATOK)を施したカスタマイズROMで導入してみたのですが、Qtekのスプラッシュ・スクリーンで固まってしまい、そこから先に進みません・・。いきなりの挫折です。
「手順に失敗した?」と思いもう一度試してみましたが、結局同じでした。ROM作成の手順は以前と何ら変わりません(多少レジストリを増やしていますが、多分稼動実績は他の方のところであるはずです)。
ということでカスタマイズROMでの導入は断念。オリジナルROMを素直に導入して後から日本語化することにしました。
原因が今一分からないのですが、ATOKがひょっとしたら理由かな、と踏んでいます(次項参照)。
■ATOK導入時に原因不明エラー
やり直すと直ったのでクリアできたのですが、当初何故かインストール時にエラーになってしまいました。
ハードリセットして一からやり直すと直ったのですが、原因が全然不明です。
また、途中で一度カスタマイズROMの場合と同じように必要なファイルのみ取り出して(こちらで説明されている方法です)放り込んでみたのですが、リセットして再起動すると、見事にスプラッシュ・スクリーンのところで固まってしまいました。
どうもこれまでの方法ではATOKをうまくインストールできないみたいです。
カスタマイズROMの場合と同じ原因かと思われます。ちょっと工夫が必要そうですね。
■さくさく感は最高、不具合も(一部)直った!
噂どおり、動作のさくさく感は非常にいいです。
例えばアプリの起動や画面の切り替えもストレスなくなりました。
ポートレイトとランドスケープを切り替える場合、以前のROMでは大体4-5秒ぐらい待たされましたが、新ROMでは1秒以内でさくっと切り替わってくれます。またPIEで読み込みに掛かる時間も体感でかなり改善されたように思います。
全般的には恐らく描画スピードが向上したのではないかな、と感じています。この辺のチューニングが大きく全体パフォーマンスにも貢献しているのではないでしょうか。
うちの環境ではGSFinderなどでネットワークの接続が出来ない問題があったのですが、これもあっさりと直って正常動作するようになりました。
これでWiFi経由でベットサイドで映画が見られます!
■電話がかけられない?
まだあまり触りきれていませんが、タイAISのプリペイドSIMでローミング中なのですが、BankCheckにかけてもずっとWait状態のままで繋がりません。
ひょっとしたら使えなくなってる??
■Jasjap_50on.cab for i-mate 13 ROMは適用不可
Ashul師匠のJasjap_50on.cab for i-mate 13 ROMですが、導入すると突然ソフトリセットがかかった上、起動してもQtekのスプラッシュ・スクリーンが終わった後(本来WMのロゴが出るところ)で画面がホワイトアウトして死んでしまいます・・残念。現時点ではメニュー他の日本語化の道は絶たれてしまいました。
もともと微妙にバージョンが異なる(i-mateは1.30.76WWE、Qtekは1.30.77WWE)のでこれは仕方無いですね。
・・といったところが第一印象です。
全般として旧ROMの方がいいところも多少ありますが、動作のさくさく感には何物にも代えられないと感じています。使い出すともう戻れないでしょうね。
という訳で、多分僕はこのまま新ROMと心中すると思います(^^)

4 thoughts on “Qtek9000用新ROMを導入してみた

  1. h-wさん、こんにちは。詳細に手順をありがとうございます。
    そうですか。h-wさんの方ではATOK付きのカスタマイズROMでもOKだったんですね。
    違いはご指摘通り、ハードリセット直後にATOKを設定していたからかも知れませんね。
    # 以前のROMではもっといい加減に使っていても大丈夫だったような気が。その辺が今回のROMバージョンでは多少異なっているのでしょうか??
    まだ人柱モード中ですので、以上に留意して試してみます。
    ありがとうございました。

  2. こんにちは。
    こちらではQTEK新ROMにATOK+wince.nls+日中韓泰フォントを調理したものを使っています。Jasjap50onも普通にインストールできました。
    以下に、思いつく限り手順を書きます。参考にしていただければ幸いです。
    1.普通通りROMクッキング。
    2.ハードリセット後、ExtendedROMもそのまま全部インストール。
    3.リセット後、すぐに「ATOK設定」は触らない。まず以下をインストールして一旦ソフトウェアリセット。(ATOKは正規購入品です。)
    – DefSipChange
    – SIPz(手動でリンクをStartUpに入れる)
    – PocketTweak
    – レジストリエディタ
    – HappyTappingKeyboard
    – GSFinder+Uni
    – PHM PPC PowerToys
    4.起動後にGSFinderおよび各種設定(Today画面とか)変更をして再度ソフトウエアリセット。
    5.起動後、「ATOK設定」の「ATOKを日本語入力に使用」にチェックを入れ、すかさずPocketTweakの「入力パネル」で「標準のパネル」を「英数」から「Keyboard」に。で、ソフトウェアリセット。
    6.起動後に、その他色々なものをインストール。この時点でJasjap50onも入れたと思う。
    ※しばらくは何かインストールする度に「標準のパネル」設定確認とソフトウェアリセットしてました。たしかにスプラッシュ画面がでるとホッとしますね。
    ※最初、ハードリセット後に直ぐにATOKをONしたところ、スプラッシュ画面前にホワイトアウトして前に進まない現象が発生しましたが、この順番で運用までこぎつけています。
    以上、あくまで私の記憶です。実施は自己責任で。

  3. わー、Asukal師匠だっ。わざわざ書き込みありがとうございます。
    師匠のコメントを読んで、再度Jasjap 50onをインストールしてみたのですが、今度はうまくいきました。
    原因としては指摘通り、Extended ROMを初期化時に読み込んでいたかどうかではないかと思います。
    現環境では確実にExtended ROMの読み込みはスキップしています。
    エラーの時は、実はあやふやな部分ではあるのですが、全部インストールしていたような気がします。
    PT_Qtek-Certificate_UNI.CABのせいかどうかまでは分かりませんでしたが、Extended ROMが何かしらの悪影響を与えていたのではないかと。
    以上、ご報告まで。
    今後とも宜しくお願いします。

  4. このQTEKのROMですが何か独自のセキュリティーが組み込まれているようです。
    まずExtendedROM内にある
    PT_Qtek-Certificate_UNI.CAB
    と言うCABからなにやら証明書やセキュリティーの設定を組み込んでくれます。
    これが曲者の原因のかのうせがあります。
    基本的なリソースはi-mateとQtekの130では代わっていないようなのでJasjap 50onがうまくいかないのはやはり証明の関係と思います。
    近いうちには解決法を見つけます。

コメントを残す

メールアドレスが公開されることはありません。

日本語が含まれない投稿は無視されますのでご注意ください。(スパム対策)

このサイトはスパムを低減するために Akismet を使っています。コメントデータの処理方法の詳細はこちらをご覧ください